Home Forums Fishing General Fishing Forum Terrova anchor lock issues

Viewing 6 posts - 16 through 21 (of 21 total)
  • Author
    Posts
  • Avatarmskursh
    Participant
    Post count: 1174

    there is an issue with 13-16 ipilots. their tech changed and it wonky’d up the spotlock. i’ve been in probably half a dozen boats with ipilot the last few years and i’ll concede that some are crazy and some are not. no rhyme or reason.

    my ipilot is version 1 ipilot and its about as accurate as can be. it stays within 5-10′ really well.

    i’ve seen some 2nd gens work just as well and i’ve seen some just be bonkers. spinning the boat around, rushing back to the spot at 10 (this is really fun when you are standing in the bow not paying attention)

    a lot of factors obviously. i find in the dead calm, mine sometimes doesn’t know what to do. but isn’t really ever an issue. in super windy/heavy current/choppy water, it will drift a bit but not much issues.

    the new terrova/ipilot is ridiculously accurate. i like the motorguides accuracy as well. and the jog funtion was awesome but the new MK has that now as well. i just prefer the MK as i like that their remote has information on it. the MG doesn’t.

    its funny listening to people gripe about their older ipilots that are for the most part working as intended (while completely acknowledging some are not working as intended). MK broke the mold with this tech. but as soon as 7 years is up and mg comes out with their own, now all the sudden its a pile of garbage. same guys were flaunting it 8 years ago.

    AvatarCRIA1576
    Participant
    Post count: 581

    i’ve seen some 2nd gens work just as well and i’ve seen some just be bonkers. spinning the boat around, rushing back to the spot at 10 (this is really fun when you are standing in the bow not paying attention)

    EXACTLY!!! Mine is of the wonky/bonkers variety… LOL! I am going to call and see what, if anything, can be done to try and correct it.

    Avatarhenpopper
    Participant
    Post count: 51

    Quote by: mskursh

    there is an issue with 13-16 ipilots. their tech changed and it wonky’d up the spotlock. i’ve been in probably half a dozen boats with ipilot the last few years and i’ll concede that some are crazy and some are not. no rhyme or reason.

    my ipilot is version 1 ipilot and its about as accurate as can be. it stays within 5-10′ really well.

    i’ve seen some 2nd gens work just as well and i’ve seen some just be bonkers. spinning the boat around, rushing back to the spot at 10 (this is really fun when you are standing in the bow not paying attention)

    a lot of factors obviously. i find in the dead calm, mine sometimes doesn’t know what to do. but isn’t really ever an issue. in super windy/heavy current/choppy water, it will drift a bit but not much issues.

    the new terrova/ipilot is ridiculously accurate. i like the motorguides accuracy as well. and the jog funtion was awesome but the new MK has that now as well. i just prefer the MK as i like that their remote has information on it. the MG doesn’t.

    its funny listening to people gripe about their older ipilots that are for the most part working as intended (while completely acknowledging some are not working as intended). MK broke the mold with this tech. but as soon as 7 years is up and mg comes out with their own, now all the sudden its a pile of garbage. same guys were flaunting it 8 years ago.

    with the new tech right on the remote there is a setting for boat scale. so if your motor is over sized for the boat like mine is, you can dial back how hard the motor kicks on. so instead of almost getting dumped outta my bow it just smoothly rolls into the power

    AvatarStickman
    Participant
    Post count: 788

    Quote by: CRIA1576

    i’ve seen some 2nd gens work just as well and i’ve seen some just be bonkers. spinning the boat around, rushing back to the spot at 10 (this is really fun when you are standing in the bow not paying attention)

    EXACTLY!!! Mine is of the wonky/bonkers variety… LOL! I am going to call and see what, if anything, can be done to try and correct it.

    Report back to us what you find out please.

    AvatarSR Dave
    Participant
    Post count: 170

    Quote by: CRIA1576

    i’ve seen some 2nd gens work just as well and i’ve seen some just be bonkers. spinning the boat around, rushing back to the spot at 10 (this is really fun when you are standing in the bow not paying attention)

    EXACTLY!!! Mine is of the wonky/bonkers variety… LOL! I am going to call and see what, if anything, can be done to try and correct it.

    I too agree that some work fine and others are wacky. Fortunately for me, mine works just fine.

    Avatarbiglarry28
    Participant
    Post count: 26

    My experience has been similar to everyone else, 1st gen great, my 2nd gen was terrible, new motor with heading sensor is great. Call Minn Kota, I know some people have sent their motor in to be recalibrated, although the results seem to be mixed on that as well. Good luck

Viewing 6 posts - 16 through 21 (of 21 total)
  • You must be logged in to reply to this topic.